Ebay API - No Matching SKU Error (error_code: 21916270)
Incident Report for Channable
Resolved
The issue has been resolved, the implemented fix worked for all the failing cases. Should you experience the same error in the future, you can ask our support team to look into it by contacting them at support@channable.com.
Posted Aug 09, 2019 - 17:38 CEST
Monitoring
We successfully implemented a fix for this problem. We already successfully tested this fix on the staging environment. We can now easily fix this problem for the failing ebay APIs, the fix is not turned on by default for all ebay APIs, just the ones that experience this particular problem.
Posted Aug 09, 2019 - 15:31 CEST
Identified
We have successfully identified that the problem is in the usage of the SKU as the product identifier. When switching the product identification to the product_id when sending a product update, this succeeds without errors.

We will now start to think of a proper implementation of a fix.
Posted Aug 09, 2019 - 11:10 CEST
Investigating
We have noticed an issue going on with some of our Ebay APIs in the last couple of days. The issue is that we cannot update products on Ebay any longer due to the error mentioned in the title of this. We are not entirely sure yet why this is happening. The only thing we know is that currently we always sent updates and creations with the SKU as the identifier of the products and we're looking into switching this to product_id instead.

The Integrations team is currently doing trials and errors regarding the above. We will post an update if we find more.
Posted Aug 09, 2019 - 10:27 CEST
This incident affected: Marketplaces.