Delays in image downloading

Incident Report for Channable

Resolved

Our backlog has been cleared and everything is operational.
Posted Aug 08, 2025 - 13:40 CEST

Monitoring

A fix has been deployed and we are making progress towards our backlog. We expect to have caught up in a few more hours.
Posted Aug 07, 2025 - 17:05 CEST

Identified

We are seeing delays in fetching images for our creatives suite. New images may be delayed by several hours. Images that have already been downloaded into our systems will function as normal. The problem has been identified and we are working on a solution.
Posted Aug 07, 2025 - 15:39 CEST
This incident affected: Creative suite (Dynamic Image Editor).