Not reachable by phone

Incident Report for Channable

Resolved

This incident has been resolved.
Posted Jan 19, 2026 - 09:45 CET

Update

We are continuing to work on a fix for this issue.
Posted Jan 19, 2026 - 09:45 CET

Identified

Our phone provider is experiencing issues with their authentication system. This means our support department is not reachable by telephone. We are still reachable through all other means
Posted Jan 19, 2026 - 09:07 CET
This incident affected: Support (Inbound Calls).