Degrade performance for Insights dashboards
Incident Report for Channable
Resolved
We are no longer experiencing any problems with our Insights imports in Channable. Operations continue to run successfully and Insights dashboards work as expected.
Posted Aug 06, 2024 - 15:42 CEST
Monitoring
We have reached out to affected customers with the option for a workaround, if you did not receive any message from us you can disregard this status page. Google reported that they are still working to restore reporting services, we will closely monitor their updates.
Posted Aug 06, 2024 - 09:33 CEST
Update
The disruption of Google Ads reports still continues, affecting our Insights feature. Google stated they will reach out to all impacted customers directly with further details on this incident.
Posted Aug 04, 2024 - 13:04 CEST
Identified
We have determined that there is no direct and safe workaround for the current problem.
We will have to wait until the problem is resolved on the side of Google.
If there are any updates, we will post them here.
Posted Aug 02, 2024 - 10:44 CEST
Investigating
On the Google Ads status page we were notified of a service disruption. This disruption affects our insights feature, causing the download of the data to fail in Channable.

We are currently working to determine the impact and a possible workaround.
Posted Aug 02, 2024 - 10:30 CEST
This incident affected: Insights & Analytics.