Google Ads experiencing Issues
Incident Report for Channable
Resolved
We are no longer experiencing issues. Google have confirmed the incident to be resolved.
Posted Jan 24, 2023 - 09:37 CET
Identified
We have noticed an increase in failed requests for our Google Ads integration. Google have reported that a fix is being investigated. We will continue to monitor the situation.
Posted Jan 23, 2023 - 16:18 CET
This incident affected: Ads.