eBay Order Retrieval
Incident Report for Channable
Resolved
Orders from eBay are being retrieved and processed.
Posted Sep 18, 2023 - 08:33 CEST
Investigating
We have noticed a decreased in orders retrieved from eBay throughout the day. We are looking into the situation and will continue to monitor our eBay Order Connection closely.
Posted Sep 15, 2023 - 17:47 CEST
This incident affected: Orders.