The incident has been resolved. No systems are currently affected anymore and processes are being caught up on. Do note that there still might be a small delay while we work through the backlog of tasks that got delayed.
Posted Feb 20, 2026 - 17:31 CET
Monitoring
Restarted affected services and we will monitor. Missed orders or offer updates will be picked up, although with a slight delay. Any delayed exports or imports will continue to run again.
Posted Feb 20, 2026 - 16:30 CET
Investigating
Issues loading and processing items causing the tool to sometimes not show pages correctly. We are investigating the scope of the problem at the moment.
We can see that exports, rules and creatives are mainly affected.
Posted Feb 20, 2026 - 16:22 CET
This incident affected: Channable tool, Ads, Marketplaces, and Creative suite (Dynamic Image Editor).