Phone services are unavailable

Incident Report for Channable

Resolved

Phone services are fully operational again.
Posted Nov 16, 2022 - 16:58 CET

Monitoring

Phone calls are now coming through again. We will continue to monitor the situation.
Posted Nov 16, 2022 - 15:18 CET

Identified

The software used to handle incoming phone calls to our support department is experiencing problems. We are thus not able to receive phone calls as of this moment.
Posted Nov 16, 2022 - 14:24 CET
This incident affected: Support (Phones).