This issue has been resolved. We are working through our backlog of background jobs at a normal pace again.
Posted May 12, 2026 - 12:41 CEST
Monitoring
We have implemented a mitigation and are working through our backlog of background jobs. Imports, Channel exports and other jobs are being processed.
Posted May 12, 2026 - 11:32 CEST
Identified
We have identified the cause and are working on mitigating the issue. Until the this mitigation is in place background jobs will continue processing with delays.
Posted May 12, 2026 - 11:04 CEST
Update
We are continuing to investigate this issue.
Posted May 12, 2026 - 10:49 CEST
Investigating
We have identified an issue with background processing that started around 2:15 EST. We are investigating the cause.
Posted May 12, 2026 - 10:44 CEST
This incident affected: Importing items (Shopify, Other) and Ads, Marketplaces, Insights & Analytics, Creative suite (Dynamic Image Editor), Comparison Shopping Service (CSS).