We are continuing to monitor for any further issues.
Posted Aug 15, 2025 - 11:11 CEST
Monitoring
The image downloader is experiencing heavy load. We have applied performance improvements but it will take more time for us to fully catch up with the backlog. In the meantime, this might temporarily cause a `NOT DOWNLOADED YET` error to be shown for new images that we have not downloaded before.
Posted Aug 14, 2025 - 18:19 CEST
This incident affected: Creative suite (Dynamic Image Editor).