Technical problems with our phone
Incident Report for Channable
Resolved
This incident has been resolved.
Posted Mar 22, 2022 - 18:15 CET
Monitoring
A fix has been implemented by Aircall and they're monitoring the results.
Posted Mar 22, 2022 - 18:05 CET
Identified
Aircall, our phone provider, has identified this issue and they are working on a fix.
Background information can be found by following the incident at https://status.aircall.io/.
Posted Mar 22, 2022 - 17:35 CET
Investigating
At the moment our phone provider is experiencing a technical issue. As a consequence we're not able to pick up incoming calls or make outgoing calls.

For all your urgent Channable-related questions, please contact us by email at support@channable.com.
Posted Mar 22, 2022 - 17:18 CET
This incident affected: Support (Phones).