Increased processing delays for the Google Ads API
Incident Report for Channable
Resolved
This incident has been resolved.
Posted May 12, 2022 - 10:25 CEST
Monitoring
We have received confirmation from Google that their processing times are returning back to normal. Today we are slowly allowing more Google shopping and text ads generators to run simultaneously, until we are back to our usual capacity.
Posted May 12, 2022 - 09:16 CEST
Investigating
Over the course of the weekend we have noticed increase delays in processing for requests send to the Google Shopping and Text Ads APIs. This means that we are waiting for Google to process our requests for longer than usual. Because of this, some text and shopping ads generators will seem stuck in the "generating" or "updating" stage in Channable.

We are in contact with Google to resolve the situation.
Posted May 09, 2022 - 09:38 CEST
This incident affected: Ads.